Neil Turner's Blog

Blogging about technology and randomness since 2002

Not the upgrade you were expecting


Upon logging into my WordPress dashboard, I noticed an update to WordPress was available. Alas, it wasn’t the expected WordPress 3.2, but 3.1.4 – a security fix. Therefore, if you’re using WordPress, you’ll need to update your install.

One of the reasons that originally held me back from switching to WordPress was the number of security updates released, and knowing a number of friends’ blogs that have been defaced by script kiddies in the past. However, having seen how simple it is to install WordPress updates (it can be done from within the dashboard and literally takes less than 2 minutes), I didn’t feel that this would be a major problem as I should be able to roll out security fixes very quickly. It’s certainly much easier than updating Movable Type, which has had its fair shares of security vulnerabilities lately.

WordPress 3.2 is the next reasonably-large update and is due imminently – in fact, release candidate 3 of it is also out today – but it’s not quite ready, and with the upheaval of moving from Melody I felt it best to wait until the proper release, rather than try a not-quite-fully-tested build. Despite being a point update, there are some significant behind-the-scenes changes to the code, which will hopefully make WordPress faster at the expense of dropping support for PHP 4.x and MySQL 4.x. This means that you’ll need a minimum of PHP 5.2.4 and MySQL 5.0.0 on your server to be able to run WordPress 5.2 – this should not present a problem for most users as PHP 5.2.4 came out almost four years ago and MySQL 5 is around six years old. But if it does present issues, 3.1.4 should still be available. Either way, the WordPress Requirements Check plugin will tell you whether your server has the right software for version 3.2. This one does.

Comments are closed.